Set Index.php In Wamp Server?


I have to set index.php as default in my wamp server,because each time when i open project its displaying all files and from that i have to select index.php to start

View Answers
Very similar questions



Warning: Mysql_connect() [function.mysql-connect]: Error? www.dreamincode.net

I'm working on creating a register/login form for a website I keep getting following errors I'm not sure how to fix them.Underneath these errors are my code. Notice: Undefined index: submit in C:\wamp\www\register.php on line 5 Notice: Undefined index: fullname in C:\wamp\www\register.php on line 7 Notice: Undefined index: username in C:\wamp\www\register.php on line 8 Notice: Undefined index: password in C:\wamp\www\register.php on line 9 Notice: Undefined index: repeatpassword in C:\wamp\www\register.php on line 10 [code]....

Remove Undefined Index: Name In E:wampwwwjobsiteindex On Line? www.dreamincode.net

I am new in php. please help me. How can i remove this error. The error is:Undefined index: name in E:\wamp\www\jobsite\index.php on line 4Undefined index: user in E:\wamp\www\jobsite\index.php on line 6Undefined index: password in E:\wamp\www\jobsite\index.php on line 7My code is <?php session_start(); include "connection.php"; if($_SESSION['name']=='') { [code]...

Changed Index.html To Index And Now The Page Doesn't Load? stackoverflow.com

It gives me the following message: The requested URL /cgi-sys/php-cgiwrap/gcadmin/php5.cgi/projects/globalcolleage/index.php was not found on this server. (I'm using WAMP) I think it has something to do with this hthaccess file: IndexIgnore * DirectoryIndex index.html index.HTML index.shtml index.cgi index.php index.php3 index.phtml index.htm home.html welcome.html Action application/x-pair-sphp5 /cgi-sys/php-cgiwrap/gcadmin/php5.cgi AddType application/x-pair-sphp5 .php (the file exist: D:wampwwwprojectsglobalcolleageindex.php)

Notice: Undefined Index: Action Index On Line 3 / Error? www.sitepoint.com

Notice: Undefined index: action index.php on line 3 an error occured when i submit the login form....in the previouse version of wamp it does not show this type of errors

Chrome Downloading Index.php File But Not Other .php Files stackoverflow.com

I am currently having a problem with my WAMP/Google Chrome. On my wamp server (running on windows) I have enabled the use of the httpd-vhosts.conf file and modified my HOSTS file to accept different "server" names ie. mysite and set my vhosts file to say: [code]... This works fine when I'm viewing pages such as about.php, contact.php but when I try to view the index.php file, chrome downloads the file (it does the same in rockmelt - I assume since they both based on chrome). It works fine in firefox, opera, safari and IE9 so its not the actual php file itself (also if I rename index.php to anything else it works fine in chrome). I have even changed the content of the index.php file to simply do: <?php echo "test"; ?> But Chrome still downloads the file.

Receiving An Error When Installing PEAR? stackoverflow.com

I am trying to install PEAR for use with PHP. As i read on the installation instructions at [url].. I am supposed to run the file go-pear.bat which I have in my C:wampinphpphp5.3.0 directory. According to all the installation guides I have read, it should install and ask me a series of installation questions, but I am receiving the following error: phar "C:wampinphpphp5.3.0PEARgo-pear.phar" does not have a signature PHP Warning: require_once(phar://go-pear.par/index.php): failed to open stream: phar error: invalid url or non-existent phar "phar://go-pear.phar/index.php" in C:wampinphpphp5.3.0PEARgo-pear.phar on line 1236 Warning: require_once(phar://go-pear.par/index.php): failed to open stream: phar error: invalid url or non-existent phar "phar://go-pear.phar/index.php" in C:wampinphpphp5.3.0PEARgo-pear.phar on line 1236 Press any key to continue. I'm not sure why I am receiving this error. I just installed the new Wampserver recently.

View Files On Localhost And Getting The Error? www.phpfreaks.com

I'm trying to view files on my localhost and i'm getting the error Forbidden:You don't have permission to access /dir/on this server.It works fine on our development server.Upuntil now i was working on development, but i want to work from localhost.We do use session id's for all our urls, e.g.index.php?id='page'?PHPSESSID=1234567890.I'm not sure whether thats the problem.I'm guessing it's some setting in the php.ini file.I'm using WAMP, but the same issue arises with XAMPP, so it's not the server itself.

Setting Up CodeIgniter To Show Up On Http://localhost/ci/? stackoverflow.com

I downloaded and set-up CodeIgniter and Apache. I have started my Apache server, and in my config.php file in CodeIgniter, I set the base URL to: $config['base_url'] = "http://localhost/ci/"; However, when I go navigate to that URL (http://localhost/ci/ or http://localhost/ci/index.php), I get a standard 404 Object not found error. When I navigate to localhost, I see the WAMP home page. Not sure if there is anything else I need to set up.

Programming :: Php Didn't Reload - Cache? www.linuxquestions.org

I make personal site with php on wamp. When uploaded it to my debian box I make some comments in index.php like Code: //include(realpath('inc/inc.php')); echo realpath('inc/inc.php'); upload the changed php file, but when try to reload the site same errors stay there. There is some cache that I have to clear but I don't know where it is. In wamp I clear wamp mp* directory What cache I have to clear? Edit: It is not my browser. I use firefox and clear everything with several times ctrl+shift+del I even delete index.php but the same errors stay at the page: Code: Warning: include(inc/inc.php) [function.include]: failed to open stream: No such file or directory in /var/www/site/index.php on line 3 Warning: include() [function.include]: Failed opening 'inc/inc.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/site/index.php on line 3

Connect Netbeans With Wampserver? www.dreamincode.net

Well i have installed the latest Wamp server, got it to work and iv installed netbeans with the php template. Now the problems starts:1st, How do i connect netbeans to my wamp server? Localhost doesnt work.2nd, how do i set up the server to be ready to connect websites to it?iv only worked with html and css, pknow its not all php related but its needed for me to start php programmin


Windows - Run A Script As A Background Process In Wamp Server? stackoverflow.com

I have two php scripts that need to be run as continuous back ground processes in WAMP server. Wamp server is installed in window 7 PC. These scripts are already reside in separate folder in the www root directory. Apache Version :2.2.8 PHP Version :5.2.6 Since this is not a unix platform I can't use nohup php script.php > /dev/null & command to do this job. I'm looking for similar kind of command or method which works in wamp server windows platform.

Error With Mysql - Web Servers & Hosting? www.dreamincode.net

i am using windows vista and installed wamp server, initially i installed wamp and accessed phpmyadmin and while setting a password for the root i did a mistake and could not access phpmyadmin and also renamed some php files so i uninstalled wamp server and re installednow the problem i am facing is when i click on mysql.exe located at D:\wamp\bin\mysql\mysql5.1.36\bin i am getting the following errorerror 2003 cant connect to Mysql server on localhost 10061in config.inc.php located at d:\wamp\apps\phpmyadmin3.2.0.1 i have the following $cfg['Servers'][$i]['host'] = 'localhost'; $cfg['Servers'][$i]['port'] = '3306'; [code]....

Access PotgreSQ Using Wamp Server? bytes.com

I am developing application using php and mysql through wamp server. but due to some requrement i shall have to use potgreSQL instead of mysql. I dont know how to configure the wamp server to do this. how to access potgreSQL through php using wamp server

Include_path='.;C:5pear' / Fatal Error: Require_once() [function.require]? stackoverflow.com

how can i set include_path C:wampinphpphp5.3.0php.ini file i want to set the include path in php.ini file include_path = ".:c:/wamp/www/bin/php5.3.0/php.ini" i have set this path but i got the error Warning: require_once(super/pms_global.inc.php) [function.require-once]: failed to open stream: No such file or directory in C:wampwwwPMSwwwindex.php on line 10 Fatal error: require_once() [function.require]: Failed opening required 'super/pms_global.inc.php' (include_path='.;C:php5pear') in C:wampwwwPMSwwwindex.php on line 10

Sockets Not Working stackoverflow.com

I switched from Lighttpd server to WAMP and then found sockets in php are not working. But php is configured and working. (phpinfo() works) I removed the comment for the php_sockets.dll in php.ini @ C:wampinphpphp5.2.5.but still gives the error "Fatal error: Call to undefined function socket_create()". Any more configurations to do to enable sockets in php in WAMP? (php_sockets.dll is there as well, I've checked)

Windows Vista And Installed Wamp Server? www.phpfreaks.com

i am using windows vista and installed wamp server, initially i installed wamp and accessed phpmyadmin and while setting a password for the root i did a mistake and could not access phpmyadmin and also renamed some php files so i uninstalled wamp server and re installednow the problem i am facing is when i click on mysql.exe located at D:wampinmysqlmysql5.1.36in i am getting the following error error 2003 cant connect to Mysql server on localhost 10061 in config.inc.php located at d:wampappsphpmyadmin3.2.0.1 i have the following $cfg['Servers'][$i]['host'] = 'localhost'; $cfg['Servers'][$i]['port'] = '3306'; [code].....

Can't View Public Folder Of Zend Framework Project? stackoverflow.com

I recently started learning zend framework. I am trying to access the index.php inside the public folder, but when i test the project using WAMP server in browser, I can't find the public folder in the web root. I can see other folders like applications, library, docs but there isn't any public folder. Why can't I view the public folder of Zend Framework Project? UPDATE my .htacess file inside the /public folder RewriteEngine On RewriteCond %{REQUEST_FILENAME} -s [OR] RewriteCond %{REQUEST_FILENAME} -l [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^.*$ - [NC,L] RewriteRule ^.*$ index.php [NC,L]

Apache - Disable Directory Including All Sub Directories With .htaccess stackoverflow.com

I'm making a website which allows people to upload files, html pages, etc... Now I'm having a problem. I have a directory structure like this: -/USERS -/DEMO1 -/DEMO2 -/DEMO3 -/etc... (every user has his own direcory here) -index.php -control_panel.php -.htaccess Now I want to disable PHP, but enable Server-side includes in the direcories and subdirectories inside /USERS. Can this be done BTW, I use WAMP server

Document Root Not Working? www.sitepoint.com

I am using WAMP Server 2.0 which includes - Apache 2.2.11 - MySQL 5.1.36 - PHP 5.3.0 -Dreamweaver CS4 php includes works if I use either of these on index.php PHP Code: <?php�require_once('inc/main_menu.php');�?> or <?php�include('inc/main_menu.php');�?> [code]....

Initial Setup Problem www.phpfreaks.com

I made a very simple page called index.php, and it goes to the Firefox browser and says Opening with dialog box appears and if I say open with Firefox it opens another window the TEST phpinfo() works, I installed with WAMP base. <p>This page was created at <?php echo date("h:i:s a", time()); ?> on the computer running PHP.</p> As a Html file it works, it just does not show the PHP stuff ok= index.html not ok = index.php

Apache :: ReWrite Doesn't Work Correctly www.apachelounge.com

Yesterday i was putting a website to manage in localhost but i had to abilitate the usage of mod_rewrite. when i'm in the index and i try to open links i have this message..The requested URL /c3click.php was not found on this server.Here are the steps that i followed: 1) Search for LoadModule ReWrite and decommenting 2) Search for Servername localhost <Directory /> AllowOverride all Require all granted </Directory> 3) Search for C:/wamp/www Options all # # AllowOverride controls what directives may be placed in .htaccess files. # It can be "All", "None", or any combination of the keywords: # AllowOverride FileInfo AuthConfig Limit # AllowOverride all # # Controls who can get stuff from this server. # # Require all granted # onlineoffline tag - don't remove Order Deny,Allow Allow from all Allow from Allow from ::1 Allow from localhost 4) Reboot the server In the beginning of my .htaccess file there's written RewriteEngine On RewriteBase / Options -Multiviews My configuration is Windows 7, Apache 2.4.4 on Wamp Server 64bit. In the apache_error.log file i discovered this [Wed Oct 02 10:33:47.582049 2013] [:error] [pid 2412:tid 1496] [client] script 'C:/wamp/www/c3click.php' not found or unable to stat, referer: http://localhost/Lavoro/C3click/01-10-2013_Sito/

Install PDT For Eclipse So Use The Code? www.dreamincode.net

I installed PDT for eclipse so I can use that do code PHP. I can get my programs to run in the eclipse IDE but I would like to be able to test them on Firefox. I am using WAMP and I know the code files should be in the server dir but besides manually transfering them into the WAMP dir is there a setting I can do in eclipse to make this happen automatically?Also is Eclipse worth writing PHP in, or is something like notepad++ just as good?

Setting Up 5 (Wamp) Server Looking For Suggestions. phpbuilder.com

We are setting up our own ISP (server) with Windows 2003 Standard Edition, Ms SQL 2005 and Wamp and our consulting company is setting up the hardware (and 2003 server software along with MS SQL 2005) and I am going to setup WAMP on it (with PHP5) and was looking for feedback on the PHP5 settings. Has anyone setup a 'true server' like this? I have my personal machine with WAMP and PHP5 but it is not hosted on the Internet only our Intranet, so I am safe with the standard settings and not concerned about security or speed.

Ubuntu Servers :: Control Panel For Apache - Php - Mysql Like In Xampp ? ubuntuforums.org

I have been using wamp on an xp box and now have set up ubuntu with the localhost server seeming to be going okay. As this is just a desktop graphical test server with no real public hosting, I was hoping to find a control panel like in wamp where one can stop/start php, apache, mysql, phpmyadmin and see logs etc.

Java Bridge - Installation Options In Javabridge In Wamp Server? stackoverflow.com

I am installing php/javascript in my wamp server using the folloing tutorial.[URL]....But when i run phpinfo() , there are no java configuratiion.i use windows 7if any good tutorial

Fatal Error: Call To Undefined Function Oci_connect() www.daniweb.com

i am using oracle 10g with php (wamp server) but i try to connect that return this error : Call To Undefined Function oci_connect() note :(extension=php_oci8.dll) is enable

Call To Undefined Function Printer Open()? stackoverflow.com

Ive been googling around on how to install the php_printer.dll for wamp server, nothing came up.Perhaps, anyone know how to install that ext?Basically, im trying to use php printer function and i need that extension. [URL]... Call to undefined function printer open().html to install on wamp server, but still give me error in the webpage?added the extension:php_printer.dll in php.ini testing code. Code:<?php $filename="test page"; ob_start(); [code]...

Setting Up An Intranet Site Using Wamp forums.devshed.com

These are the settings which I've created on the Wamp server that will be access across the network. In the httpd file, I have Remove the hush from the line second line of after the Virtual hosts # Virtual hosts Include conf/extra/httpd-vhosts.conf To setup the domain, in the httpd-vhosts file, I have create this <VirtualHost *:80> ServerName MathewBrown ServerAlias MathewBrown DocumentRoot "C:/wamp/www/MathewBrown" ErrorLog "C:/wamp/www/MathewBrown/logs/error.log" CustomLog "C:/wamp/www/MathewBrown/logs/access.log common" <Directory "C:/wamp/www/mathewbrown/"> Options FollowSymLinks AllowOverride all Order Allow, Deny Allow all </Directory> </VirtualHost> <VirtualHost *:80> ServerName DevServeWeb DocumentRoot "C:/wamp/www" ErrorLog "C:/wamp/www/logs/error.log" CustomLog "C:/wamp/www/logs/access.log common" <Directory "C:/wamp/www/mathewbrown/"> Options FollowSymLinks AllowOverride all Order Allow, Deny Allow all </Directory> </VirtualHost> In the hosts file, I have added this. localhost MathewBrown DevServeWeb In my phpmyadmin file, these have been added <Directory "c:/wamp/apps/phpmyadmin2.11.6/"> Options Indexes FollowSymLinks MultiViews AllowOverride all Order Allow,Deny Allow from all Allow from Allow from </Directory> <Directory "C:/wamp/www"> Options Indexes FollowSymLinks MultiViews AllowOverride all Order Allow,Deny Allow from all Allow from Allow from </Directory> <Directory "C:/wamp/www/MathewBrown/"> Options Indexes FollowSymLinks MultiViews AllowOverride all Order Allow,Deny Allow from all Allow from Allow from </Directory> Computers which will be accessing the server, their hosts file have been changed to this. localhost MathewBrown DevServeWeb

Javascript - Beginner - Pass Variable From One Code Segment To Another ? stackoverflow.com

I have index.php which uploads a file to server and sets several PHP variables (like $target_folder_and_file_name). index.php also has the following line (it was originally index.html): <script language="JavaScript" src="main.js.php"></script> After index.php returned to the browser, the browsers asks for main.js.php from the server (right?). Can I access somehow $target_folder_and_file_name from the PHP code in main.js.php ?

ActionScript 2.0 :: Make A Xmlsocket Chatroom In Computer With Wamp Server? www.actionscript.org

i want to make an xmlsocket chatroom in my computer with wamp server ,i use this port and ip: HTML Code: mySocket.connect("localhost", 1026); and i have changed the port of wamp server to 1026 and i have puted the socket.php file in www directory of wamp.when i run the swf file in flash the connection establishing is succesfull but when i try to send data the connection will close.this is the actionscript code: HTML Code: mySocket = new XMLSocket(); mySocket.onConnect = function(success) { if (success) { [code]....

Installing Pear On Wamp Server With Version 5.2.5 www.dreamincode.net

I am trying to install pear on my windows 7 system using wamp server and php version 5.2.5 I followed all of the instructions in my book - Beginning PHP 5.3 - to the letter and the install appeared to go fine. I then installed a simple pear package with all the dependencies. When I run my script I get the following errors: Warning: require_once(Net/UserAgent/Detect.php) [function.require-once]: failed to open stream: No such file or directory in C:\wamp\www\quotations\test.php on line 10 Fatal error: require_once() [function.require]: Failed opening required 'Net/UserAgent/Detect.php' (include_path='.;C:\php5\pear') in C:\wamp\www\quotations\test.php on line 10 Here is my code: <html> <head> <title>Browser Information</title> <link rel="stylesheet" type="text/css" href="common.css" /> </head> [Code].... My feeling is that I need to do something to the php.ini file but the during the installation it said it was going to set that up too.

Session Doesn't Work In Wamp5? stackoverflow.com

I'm stuck up with php sessions its not working i jus checked for basic programs in session ses.php ses1.php The above prog doesn't work. dont know prob wit prog or wamp server. I have turned ON register_globals in php.ini also i checked with session.save_path="c:/wamp/tmp" session.save_handler= files.

Upgrade System From Windows Xp To Windows 7 stackoverflow.com

I upgraded my system from Windows xp to windows 7. When i was in win xp i used the wamp server with php version 5.0 now i installed the wamp server with the version 5.3. But now it's making problem. The old projects are not running. Even-though they are created in php version 5. How i can solve this problem?

Header Warning "Cannot Modify Header Information - Headers" Message After Upgrading It www.phpfreaks.com

I just formatted my HD and had a WAMP setup.�I have not installed each component separately (newest versions). When I type in a text box and press the submit button, I get: Warning: Cannot modify header information - headers already sent by (output started at D:WebApachehtdocsprojects ms_newfunctionsfunctions.js:304) in D:WebApachehtdocsprojects ms_newappsindex.php on line 167 Line 304 in the functions.js file is:��</script> Line 167 in index.php is: header('Location:�index.php?lastname='.stripslashes($lastname)); It says I am sending header information before line 167, but there isn't any.� The .JS file only has JS code.

"Fatal Error: Interface 'Chargeable' Not Found ? www.phpfreaks.com

I'm playing around with interfaces and OOP PHP and I've set up an interface class and a class which implements it however when I run the script form the browser on my local server I get the following error: "Fatal error: Interface 'Chargeable' not found in C:wampwwwoopclass_ShopProduct.php on line 4" Here are the two classes: interface Chargeable { ���public function getPrice(); } class ShopProduct implements Chargeable[code].... I'm running Windows 7 with WAMP server 2.0 (PHP 5.3.0 & Apache 2.2.11)how it's not working when it seems like it should.

Getting Error When Sending A Mail From Wamp Server : Failed To Connect To Mailserver At "localhost" Port... www.phpfreaks.com

I had tried sending a mail from wamp server. But this message appeared. "Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:wampwwwookmailform.php on line 13 What port number should I set in php.ini now?

Install Failing To Find Today.php www.sitepoint.com

I searched the forum for previous users with the same problem and found only old posts that didn't seem to address my issues -- just so you don't waste time wondering if I've been some sort of lazy bum. In a nutshell? The infamous Kevin Yank "today.php" file refuses to be found by my server. Using Yank's tutorial, I installed the latest WAMP on my Windows XP machine which gave me the following: - Apache 2.2.17 - PHP 5.3.3 - MySQL 5.5.8 (32 bit) - PHPAdmin http//localhost (launched from the WAMP console) is finding the index.html file, it's NOT "finding" the today.php file in the same folder (htdocs) (my extensions are turned on, so the file's not named today.php.txt) URL used >> [URL] RESULT >> (The requested URL /today.php was not found on this server.) I went back and scoured the config files that I thought would have been automatically configured by the WAMP install and discovered that they hadn't been. So I made the following changes in the PHP.ini and httpd.conf files, and it still didn't work: doc_root = "C:wampinapacheApache2.2.17htdocs"extension_dir = "C:wampinphpphp5.3.5ext" (note that the WAMP install had that line but the slashes were forward - I commented it out with a semicolon) [Code]....

Php :: Configuring Propel Return Type For Flex? stackoverflow.com

I use wamp server and Propel.I have written my service using Propel but when I want to connect the data returned from the service Flex cannot recognize the return type.This is the php code that I wrote <?php // Include the main Propel script require_once 'C:/wamp/propel/runtime/lib/Propel.php'; [code].....

Database - (WAMP) OCI8 Driver Setup ? stackoverflow.com

I need to install oci8 drivers for PHP, but I’m having some trouble.I already have a WAMP install, which comes with the oci8 extension, and have done the following in effort to set it up: Enabled the extension by adding the following to my php.ini file in my Apache docroot as a local variable: [PHP_OCI8] extension=php_oci8.dll Added my extensions directory path to my PATH environment variable on windows (c:/wamp/bin/php/php5.3.0/ext/;) Added the same extensions directory to my php.ini file When I start up my wamp I see the following error message: PHP Startup: Unable to load dynamic library ‘c:/wamp/bin/php/php5.3.0/ext/php_oci8.dll’ I’m able to verify that the above path is correct, and am tempted to say that there’s something wrong with the .dll, but I’m not sure.

Wamp - Parse Error "expecting `T_STRING' In C:wampwwwProjetUser.php" stackoverflow.com

I'm trying to build a dynamic php site using MVC principles. I'm using WAMP on Win XP. Here's the code: Index.php:<?php require_once("User.php"); session_start(); include ("Header.php"); include ("Footer.php"); ?> Header.php: [Code]..... This code causes a php error on line 9 of User.php, i.e., at the get function declaration. The error message is: Parse error: parse error, expecting `T_STRING' in C:wampwwwProjetUser.php on line 9

Include Remote File In 5.x? stackoverflow.com

I am need to include some resource (non php) in our php application[URL] It is required to use the include function like that:[URL] I've set the allow_url_include = On and allow_url_fopen = On but no way! I think I still till php engine to enable include for files other than .php, correct? How to?? I am using php 5.3.5 on win machine, WAMP Server

Tell WAMP To Treat Each Website As Its Own Root Folder? forums.devshed.com

I am using WAMP to locally edit my websites. Unfortunately, whenever I try to, say, include() a file, and treat the root as "/", [such as include("/page.php")] it takes me to the root of the www/ folder in WAMP, not the root of the actual site (which is the www/ on my server, but not locally) is it possible to tell WAMP to treat each site as its own root folder?

Actionscript 3.0 :: ZendAmf Will Not Work On Webserver www.gotoandlearnforum.com

ive tested my files countless times using WAMP but when i put them on my webserver i cannot get anything to happen when i call the swf [Code]... when i goto index.php i see "Zend Amf Endpoint", and as i already said when i use a backup copy of my_db using WAMP i receive the information

Applications :: Mamp To Wamp Path To File Index.php? forums.macrumors.com

Just trying to load my wamp sites on mamp. Copied my folders into htdocs and it says to change to the wamp path file for index.php. I looked it up copied what I thought was the code needed and now all is broken.

Namespace Autoload Works Under Windows But Not On Linux stackoverflow.com

I have the following php code: index.php <?php spl_autoload_extensions(".php"); spl_autoload_register(); use modulesstandard as std; $handler = new stdhandler(); $handler->delegate(); ?> [Code]..... Under Windows 7, running WAMP, the code produces the message "Hello from Delegation!" however under Linux, I get the following: Fatal error: spl_autoload(): Class modulesstandardhandler could not be loaded in /var/www/index.php on line 15 Windows is running PHP 5.3.0 under WAMP, and Linux is running the 5.3.2 dotdeb package under Ubuntu 9.10. Is this a configuration issue on my linux box, or just a difference in the way namespaces and autoloading is handled on the different operating systems

Can't Get Curl() To Run From Command Line? www.phpbuilder.com

I have wamp installed on my system (Windows 7 and I have no other server / php set up on this machine) and am trying to run a script that uses curl() ( curl_init() ) through my local server.I have enabled php_curl() on my wamp extensions and have checked the php.ini file in both my php/bin and my apache/bin folders and both times, the line "extension=php_curl.dll" does NOT have a semi-colon in front of it. Now, when I try and run the command through the command prompt, I get the error: Fatal error: Call to undefined function curl_init() in C:wampwwwauctionsscriptsauctionRequester.php on line 28 ... And line 28 of Requester.php simply says "$this->curl=curl_init();" A strange thing, though, is that when I run phpinfo(), I get that: Configuration File (php.ini) Path = C:Windows BUT it also says for the curl portion that: cURL support = enabled cURL Information = 7.19.4 Age = 3 I am truly at wit's end here - I don't know why this is happening or what to do about it... I am THINKING it has something to do with running the php command at the command line, but I don't know what needs to be done so as to make it run well.

Save A Gzipped Html File On Server? stackoverflow.com

I use this script to automatically save a PHP-file into a HTML file on my server: <?php $page=file_get_contents('http://yourdomain.com/index.php'); $fp=fopen('index.html','w+'); fputs($fp,$page); fclose($fp); ?> How can I get the server to also save a Gzipped version of index.php on the server? The goal is to have the following files in the folder: turn-indexphp-into-indexhtml-and-indexgz.php index.php index.html index.gz

Install Curl Extension On Wamp Server WIN XP? stackoverflow.com

I have WAMP SERVER,PHP 5.3.0 and Apache server 2.2.11 I want to download a suitable CURL lib version for it. I studied the sites and found that this installation will not be easy it may not work if the version is not suitable I found here: [URL] but I'm not sure to get the perfect result cause my version is different also I have another problem if I can not install it in a good way will my wamp server and databases go wrong or not?

WAMP Set-up: Cannot Access MyAdmin From Another Machine? forums.devshed.com

I've downloaded WAMP 2.1 and it's working just fine on the localhost machine. I can access phpmyadmin with no issues. However, I cannot access phpmyadmin on another LAN machine. I have edited the phpmyadmin.conf file which now reads: <Directory "c:/wamp/apps/phpmyadmin3.3.9/"> Options Indexes FollowSymLinks MultiViews AllowOverride all Order Allow,Deny Allow from all </Directory> but it still gives me the "You don't have permission to access /phpmyadmin on this server." error.I can access my index.htm file on the other LAN machine. This webpage has a link to phpmyadmin (which gives the error) as well as a link to some fill-able forms on the server (which work just fine). All the solutuions online point to editing the phpmyadmin.conf file, but I've already done that, restarted the WAMP server and I get the same error message.

Apache Server On Wamp Won't Start forums.digitalpoint.com

I am using Wamp server 2.2. I recently made some changes to the Apache configuration to allow me to make a virtual host for the Zendframework. the change i made were as follows: <VirtualHost> ServerName zendy DocumentRoot "C:workspacezendypublic" SetEnv APPLICATION_ENV "development" <Directory "C:workspacezendypublic"> DirectoryIndex index.php AllowOverride All Order Deny,Allow Allow from all </Directory> </VirtualHost> Since these changes were made, my wamp server will not start up. the wamp bar remain red. What I have to do to find out/trace where the fault is?

Default Pages Not Loading Without "/" www.webhostingtalk.com

Hard to describe the situation in the subject so here is the spill: CentOS Server cPanel While getting my new server ready to move my main site over to I have a problem with default PhP pages not loading correctly. I set index.php to be a default page in .htaccess but the default page won't load unless a trailing "/" is used in the url. Example: [url] ----- Works fine, loads index.php [url] ----- Does not load index.php or any other default page I'm sure this is one of those easy settings I have just overlooked .

Email - Failed To Connect To Mail Server stackoverflow.com

I have written a small piece of PHP code for sending mail: [Code...] Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:wampwwwNewHishobPhpFilessend_mail.php on line 11 Mail failed I am using a WAMP server and there are two files, INI-DIST and other is INI-RECOMENDED. Which one is important? I had also gone through php.ini-dist file and for SMTP it contains the following: [Code....]

Start The Session On A Sub-folder bytes.com

I've got a Php 4.3.3 installation on A Red Hat Advanced Server 2.1. Sessions start correctly if i start them from the server root. But, if i start the session on a sub-folder, when i change to a folder that's not below it, the session gets started again. Let's see an example When i begin from the document root all goes as expected... Open /index.php -> session id = A Open /folder1/index.php -> session id = A Open /folder2/index.php -> session id = A But when i begin on a subfolder....... Open /folder1/index.php -> session id = A Open /folder1/index2.php -> session id = A (inside the same folder the session is mantained) Open /folder1/subfolder/index.php -> session id = A (on a sub-folder the session is also mantained) Open /folder2/index.php -> session id = B (on a folder that's not below the first, the session starts again!!!!!!!!) Open /folder3/index.php -> session id = C It's like if the session were only set for the current path and downwards, but not the entire server... Any thoughts?

Cannot Load Mysql Extension Error With WAMP phpbuilder.com

i just intalled WAMP and when i try to open phpmyadmin this shows. Cannot load mysql extension. Please check your PHP configuration. i seen a few trouble shoot and they all say to change the path in windows and all of that but every where i look is set up right WAMP sets everything to work in the directory that is set up i dont know why this shows.

Work With PDT And WAMP? stackoverflow.com

I have installed PDT for Eclipse and WAMP server. I want to know how do i start writing code in PHP now? What should I do so that WAMP gets all my PHP files?

Variable Won't Print Before Defining It? stackoverflow.com

I'm using a portable WAMP package "USB web server". It is giving error if i try to echo some variable directly, for example <?php echo $abc; ?> The error i get is: "Notice: Undefined variable: abc " This will work fine: <?php $abc = "foo"; echo $abc; ?> Is it possible to fix this error? am bound to use portable WAMP package as I do no thave administrator privileges, so i can not install any other package.

Install WAMP And LAMP? forums.mysql.com

I am just about learning PHP language but I have good video tutorials.The first step is to install WAMP, LAMP.. i.e. to choose which one suits to my needs.The guy on the tutorial leads step by step how to do everything but installs WAMP server 1.7 because at the time the tutorial was being produced it was the latest release.On this tutorial I need to install WAMP server on my PC, develop my php files, be able to use them locally and when I am ready, I upload them and use on my server which is Bluehost. My PC-s OS: Windows 7 (32 bits) MySQL version:5.1.47-community-log (but this is found in phpMyadmin: MySQL client version: 5.1.56) PHP version: 5.2.17 Apache version 2.2.17 [code]...

WAMP Server With PEAR Working www.sitepoint.com

Does anybody know a WAMP server where pear is actually working so also CLI.. as i tried so many but they all seem to work like crap *edit Wrong forum can anybody move it *edit #2 Umm actually i mean a WAMP Development server like XAMPP can anybody put it in PHP forums

Hosting www.sitepoint.com

i have transferred my site over to a new host and I keep getting these errors when I log out. Warning: Cannot modify header information - headers already sent by (output started at /home/user/public_html/index.php:6) in /home/user/public_html/index.php on line 130 Warning: Cannot modify header information - headers already sent by (output started at /home/user/public_html/index.php:6) in /home/user/public_html/index.php on line 131 There is a setting on the server that is producing these errors. What could be causing this?

Failed To Connect To Mailserver www.dreamincode.net

im trying to send an email when there is an error to my email account, problem is i'm getting this error... Warning: error_log() [function.error-log]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:wampwwwerrorscript.php on line 8 what i should do to resolve this? i have a feeling i may need to install a smtp server on my machine as php/wamp isn't capable of sending the email without it?

Call Redirect Page Using Header On Main Web Server? stackoverflow.com

When i am testing my site on local php server using wamp the its all working fine.I am calling some of page using php file and its working fine. header( "Location:" ); But when i try to load my page on main web server likeheader( "Location: web.php" );then its not workinghow can i access my page on main web server using PHP in my website.

Email - Mail() Function Does Not Work With WAMP Default Installation ? stackoverflow.com

I have a default installation of WAMP Server 2.0.I'm trying to send email using this simple script: <?php if (mail('my_email@gmail.com', 'My Title', 'Some Text')) { echo "OK"; } else { [code].... Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:My_Pathsend_email.php on line 3 Why ??

Htaccess Mod_rewrite Not Working On Another Computer? stackoverflow.com

So I have an .htaccess file in a framework I am currently working on and it works on one computer but not on another. Both systems are windows 7 based and both are running WAMP Server 2.0. RewriteEngine on RewriteBase /home/ RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.+) index.php/$1 [L]

WAMP Upgrade - Now MYSql Not Working www.sitepoint.com

I have been running WAMP on my local server for sometime but I needed to upgrade so I downloaded the latest version, stopped WAMP and installed the new version. The Php is working ok but the MySQL service won't start and I even tried starting it in the Services. When I browse to MyPhpAdmin I get this error: Error MySQL said: #2003 - The server is not responding

Setting Directory Read/write Permissions With WAMP And IIS www.sitepoint.com

I'm using WAMP and IIS for the first time so bear with me if I overlooked something obvious. I have a simple script that creates a few files and then attempts to move them to a subdirectory. I am getting a permission denied error when attempting to move the scripts in WAMP. I am uncertain how to set directory permissions in WAMP. I am also unsure how this will affect the script when I migrate it to an IIS server.

Setting A Password For Db On WAMP 2.0? forums.devshed.com

I have WAMP server 2.0 installed. There is no password to access mysql. I tried using the MySQLInstanceConfig, but it states the template configuration file cannot be found at E:wampinmysqlmysql5.1.36inmy-template.cnf. So how exactly can I set a password for mysql on wamp?

Installing Pear With Wamp - Could Not Open Input File: "PEARgo-pear.phar" www.sitepoint.com

I'm having problems installing pear on my local machine that has Wamp installed. Full setup as follows Windows XP Pro Wamp Server Version 2.0 php 5.3.0 I'm reading all over the net that pear has install issues with php 5.3. if i open a dos window and type C:wampinphpphp5.3.0go-pear.bat. I get an error saying: Could not open input file: PEARgo-pear.phar I've tried the workaround that is stated as getting round this problem php -d phar.require_hash=0 go-pear.phar but this doesn't work as I get this error Could not open input file: go-pear.phar I have tried the non-pharred version from [URL] and run it in the command window using the command below and also from a browser window by pointing to go-pear.php php -q go-pear.php I get lots of "PHP Deprecated: Function ereg() is deprecated in" errors and the install doesn't go correctly.

Basic Script To Test A Cookie - Browser And The Cookie Wont Show Up On The Page? www.dreamincode.net

I have a basic script to test a cookie. Login.php <?php include('connect.php'); $username = $_POST['username'];[code]..... Error: Undefined index: user in C:\wamp\www\scripts\menu.php on line 14 I looked in my browser and the cookie is there with the right name but it wont show up on the page.

WAMP Apache Selectively Refusing To Parse Pages? stackoverflow.com

I have many years experience of working with Apache/PHP/MySQL directly and have only just started using WAMP. I installed WAMP last week and had my first 4 PHP/MySQL websites up and running immediately. How much easier is this I began to think! That is until I added a fifth site and cannot get php to parse any php file below the websites root directory. I have a test.php file containing just the word 'hello', ho HTML tags and no PHP directives. If I place this into /wamp/www/ob/test.php it works, if I place it into /wamp/www/ob/html/test.php the browser comes up with 'You have chosen to open test.php, what should Firefox do with this file? Basically php failed to parse it. My other sites are working fine with identical setup and this site plus three others were downloaded using Filezilla.

Asp.Net Can Run In One Single Booting Computer? www.sitepoint.com

I have single booting OS (Windows XP). I installed WAMP server for working on PHP website. It is working properly. Now I want to installed IIS and then Visual studio. Net 2003(1.1). When I run asp.net application then WAMP home page is not coming. How can I run Asp.Net application as well as Wamp home page (means PHP Web site).Means when I work on asp.net application then Wamp is not disturbing as well as when I work on php page and my sql then IIS (.net 1.1) not disturbing. I run only one at a time.

Alias An URL In Apache In Order To Route Requests On A Certain URL Through A Script? stackoverflow.com

I am using Apache 2.2.6 with suPHP 0.6.2 and PHP 5.2.6 and I am trying to use an Alias in order to route all requests on a certain URL trough a PHP script. I want all requests to /test to go through index.php. In the Apache virtualhost config I have set up an Alias Alias /test /index.php. index.php is just a dummy script containing the following: <?php phpinfo(); ?> Requesting http://localhost/index.php works and gives the expected output, however requesting http://localhost/test does not and gives me a 403 error, the error.log contains the following: [Wed Jan 27 17:13:19 2010] [error] [client] client denied by server configuration: /index.php What is wrong with my Alias? Edit: I almost forgot to mention that rewriting /test to /index.php through mod_rewrite works as well, however I want to avoid mod_rewrite on my production server if possible.

Php - Wamp Server Differ From A Normal Internet Hosting Provider? stackoverflow.com

I am using wamp server to develop a website using php, mysql, PDO, html and css. My wamp server is using PHP 5.3.5, MySQL 5.5.8 and Apache 2.2.17, I am also using InnoDB for transactions. Considering that my internet hosting provider has at least these versions of php, mysql, apache, and supports InnoDB will the website I build act in the exact same way. Is it possible to design a website in wamp and then expect several errors when going live? And if so how is this overcome?

IIS Supporting ASP.NET And LAMP Supporting Coexist On The Same Server? stackoverflow.com

Can IIS supporting ASP.NET and WAMP supporting PHP coexist on the same server? We already have a WAMP stack setup on a Windows Server 2003 box to support some internal PHP applications, and I want to also setup CI Factory on that box which will try to configure IIS to support it's ASP.NET based dashboard. I want to make sure that there isn't a big chance of fubarring the WAMP stack that is already there. Will it be smart enough to handle *.PHP through Apache and *.aspx through IIS ? Edit: Is there a way to get this to work on the same port?

Call Java Method Fom Code? www.phpbuilder.com

I have requirement i.e I want to call a java method from php code, for this i put some configurations in php.ini file java.class.path = "C:wampinphpphp5.2.5extJavaBridge.jar;C:wampinphpJavaClasses" java.home = "C:Program FilesJavajdk1.6.0;C:Program FilesJavajdk1.6.0lib" java.library = "C:Program FilesJavajre1.6.0inclientjvm.dll" java.library.path = "C:wampinphpphp5.2.5ext;C:Program FilesJavajdk1.6.0lib" [code].......

Warning Message "supplied Argument Is Not A Valid MySQL Result" In Mysql_fetch_array www.dreamincode.net

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in C:\wamp\www\test\db.php on line 28 this is the error i m getting but the data is displaying Attached File(s) index.php (1.86K) Number of downloads: 81 db.txt (1.03K) Number of downloads: 51 db.php (639bytes) Number of downloads: 25