Slackware :: Vsftpd - Any Way To Limit Upload Speed


I use vsftpd. I would like to know if there is a way to limit the upload speed. Only the upload speed so the "anon_max_rate" and "local_max_rate" don't do the job. Someone told me about the trickle but I expected a more recent application.

View Answers
Very similar questions



Server :: Vsftpd Will Now Allow Upload? www.linuxquestions.org

I have a vsftpd server configured and I cannot upload using anonymous account, I've trawled the net have have exhausted my search for answers. Here is my vsftpd.conf file Code: # Example config file /etc/vsftpd/vsftpd.conf # # The default compiled in settings are fairly paranoid. This sample file # loosens things up a bit, to make the ftp daemon more usable. # Please see vsftpd.conf.5 for all compiled in defaults. [Code]...

CentOS 5 Server :: Placing Upload/download Limit To Each Ip Using Squid? www.centos.org

I just want to place upload/download limit to each ip address ( say 20MB per day for each ip or specific ip) using squid proxy i tried through delay pool but it control only download/upload speed not place any download/upload quota restriction. following are my codes I have 1Mbps line delay_pools 2 delay_class 1 2 # here 700kbps(87Kbytes) Net-Total usage limit, with 50Kbytes per user [code]... I also used "reply_body_max_size" parameter to control upload limit. But "request_body_max_size" only restrict download based on size. how to setup quota ( download quota per day per ip)

Server :: Vsftpd - 550 Permission Denied For Upload www.linuxquestions.org

I've got that vsftpd running on a ubuntu 9.10 machine. Although I cannot upload any file, I always get a "550: Permission denied"-error. Code: # Example config file /etc/vsftpd/vsftpd.conf # # The default compiled in settings are fairly paranoid. This sample file # loosens things up a bit, to make the ftp daemon more usable. # Please see vsftpd.conf.5 for all compiled in defaults. # [Code].....

General :: Vsftpd Settingd And VSFTPD Dead But Subsys Locked? www.linuxquestions.org

i'm using redhat ent. 3.0 and w2k i want to use redhat for ftp server.i have problem with vsftp.i installed and configured using manuals.OK, it was running i could make new folders,download,upload (with local user also) but couldn't delete anything,so i changed write_enable to YES i couldn't delete again then i changed file permissions.Also looked at all files respect to vsftp -vsftpd.conf -vsftpd.ftpusers -vsftpd.user_list -/etc/xinetd.d/vsftpd /etc/init.d/vsftpd all the settings are true or i think so (according to the manuals) and now it isn't running and it gives 530 this ftp server is anonymous only error and when i want to restart or look status of /etc/init.d/vsftpd it gives stop fail and i try /etc/init.d/vsftpd stop then it says "vsftpd dead but subsys locked" all the time i tried different things i deleted /var/lock/subsys/vsftpd then i try again and again.... but i couldn't find where am i wrong.. i can send all vsftpd related files if anyone wants to help me and look up them.

Debian Configuration :: Disable Vsftpd Start On Boot forums.debian.net

I am very pleased with a new Squeeze desktop that I built. I am use to using BSD style init scripts (Slackware, OpenBSD, Arch) and am trying to tweak my system not to start vsftpd at boot. I use vsftpd occasionally to move large files between computers on my LAN. My inittab shows run level 2 as default.

Networking :: How To Limit Upload Rate? www.linuxquestions.org

I have a linux box running between my router and my LAN. My connection speed is 10MB download and 1MB upload. The issue is that whenever someone starts to upload something, it is like my connection is down. No one else can open websites, read emails etc.Is it possible to place a limit for upload, maybe 50kb/s? This way, people won't use the entire upload speed available.

Proftpd Config - How To Make Directory Have Read/write Access www.webhostingtalk.com

Followed the guide over at [url]to get proftpd setup. It only lists ways to create a single upload directory and a single download directory. Tried all possible ways to get a directory creating allowing read/write but so far unsuccessful. how this can be acheived? Here is my current config. #start of config <Directory /home/FTP-shared> Umask 022 022 AllowOverwrite off <Limit MKD STOR DELE XMKD RNRF RNTO RMD XRMD> DenyAll </Limit> </Directory> <Directory /home/FTP-shared/download/*> Umask 022 022 AllowOverwrite off <Limit MKD STOR DELE XMKD RNEF RNTO RMD XRMD> DenyAll </Limit> </Directory> <Directory> /home/FTP-shared/upload/> Umask 022 022 AllowOverwrite on <Limit READ RMD DELE> DenyAll </Limit> <Limit STOR CWD MKD> AllowAll </Limit> </Directory> #end of config /home/FTP-shared/read-write is the folder I want to be able to read and write data to.

CentOS 5 :: Errno Messages When Installing Vsftpd www.centos.org

I'm new to Linux so I'm unsure how to resolve this. I'm trying to install vsftpd in order to make our CentOS box an FTP server for backups. But I keep running into this problem when doing the "yum install vsftpd" [root@abc ~]# yum install vsftpd Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * addons: mirror.trouble-free.net * base: hpc.arc.georgetown.edu [Code]...

Server :: Vsftpd - Setup The Same Upload/download Folder For All Users? www.linuxquestions.org

does anybody knows how to setup the same upload/download folder for all users ? My vsftpd has been installed on CentOS. Its using system user. What should I put in /etc/vsftpd/vsftpd.conf to configure folder /fileserver for all users ?

Software :: Vsftpd Can't See Files To Download www.linuxquestions.org

I recently installed vsftpd and can't see any files I put in the nopriv_user folder. I want to be able to login anonymously without a password, see files to download and upload files to a pub folder. After installing and configuring vsftpd I created the ftp_priv user by doing "sudo useradd -d /home/ftp_priv -m ftp_priv". Then I added a folder /home/ftp_priv/pub with permissions 777 and a test file. vsftpd.conf Code: listen=YES port_enable=NO pasv_min_port=55000 [code]....


General :: Setup Vsftpd For FTP On Server? www.linuxquestions.org

I've setup vsftpd for my FTP on my server, I edited the vsftpd.conf to allow me user to gain access to their home directory, It doesn't seem to let me in, I'm getting the error Quote: 530 This FTP server is anonymous only. this is set at yes I've set it to NO and I get Quote: 500 OOPS: vsftpd: both local and anonymous access disabled! I don't quiet under whats going on, I followed this tutorial [URL] In the end I want to be able to upload files to the www directory for my web site.

Ubuntu :: Vsftpd Can't See Files To Download ubuntuforums.org

I recently installed vsftpd and can't see any files I put in the nopriv_user folder. I want to be able to login anonymously without a password, see files to download and upload files to a pub folder. After installing and configuring vsftpd I created the ftp_priv user by doing "sudo useradd -d /home/ftp_priv -m ftp_priv". Then I added a folder /home/ftp_priv/pub with permissions 777 and a test file. vsftpd.conf Code: listen=YES port_enable=NO pasv_min_port=55000 pasv_max_port=55100 [Code].....

Ubuntu Servers :: Add Files (and Where) For Anonymous Download - Vsftpd ubuntuforums.org

how to add files (and where) for anonymous download. I installed vsftpd and configure /etc/vsftpd.conf file...just few common options like allowing anonymous,download,upload. And now i can login with anonymous. But i dont know what to do next, i want to try to download and upload files.

OpenSUSE :: Vsftpd Chroot - Cannot Upload - 550 Permission Denied Critical File Transfer Error forums.opensuse.org

I have a problem with uploading any file to my Suse 11.1 with vsftpd. The active (not commented out) settings in my /etc/vsftpd.conf are: dirmessage_enable=YES chroot_local_user=YES local_enable=YES anonymous_enable=NO syslog_enable=YES connect_from_port_20=YES pasv_enable=YES listen=YES ssl_enable=NO And I added umask 022 to the user login script problem I have: I login with user and password that exists as a local user on my suse machine. I can read and download from my homedirectory, but I cannot upload with filezilla. Then I get the error: 550 permission denied critical file transfer error

Ubuntu Servers :: Transmission Daemon - Cannot Connect To WAN ubuntuforums.org

I have installed transmission on a headless server. I am using transmission-daemon and connects to the webclient on the LAN. However from WAN I can't connect. I have forwarded port 9091 in my router and it connects with the server, but I get 403: Forbidden. Here is my settings.json file: Code: {"alt-speed-down": 500,"alt-speed-enabled": true,"alt-speed-time-begin": 480,"alt-speed-time-day": 127,"alt-speed-time-enabled": true,"alt-speed-time-end": 0,"alt-speed-up": 10,"bind-address-ipv4": "","bind-address-ipv6": "::","blocklist-enabled": false,"dht-enabled": true,"download-dir": "/data/download","download-limit": 1000,"download-limit-enabled": 0,"encryption": 2,"incomplete-dir": "/var/lib/transmission-daemon/info/Incomplete","incomplete-dir-enabled": false,"lazy-bitfield-enabled": true,"max-peers-global": 200,"message-level": 2,"open-file-limit": 32,"peer-limit-global": 240,"peer-limit-per-torrent": 60,"peer-port": 20683,"peer-port-random-high": 20500,"peer-port-random-low": 20599,"peer-port-random-on-start": true,"peer-socket-tos": 0,"pex-enabled": true,"port-forwarding-enabled": false,"preallocation": 1,"proxy": "","proxy-auth-enabled": false,"proxy-auth-password": "","proxy-auth-username": "","proxy-enabled": false,"proxy-port": 80,"proxy-type": 0,"ratio-limit": 0.2500,"ratio-limit-enabled": true,"rename-partial-files": true,"rpc-authentication-required": true,"rpc-bind-address": "","rpc-enabled": true,"rpc-password": "password","rpc-port": 9091,"rpc-username": "transmission","rpc-whitelist": ",*.*.*.*","rpc-whitelist-enabled": true,"speed-limit-down": 1500,"speed-limit-down-enabled": true,"speed-limit-up": 50,"speed-limit-up-enabled": true,"umask": 2,"upload-slots-per-torrent": 4,"watch-dir": "/data/download","watch-dir-enabled": true }

CentOS 5 Server :: Vsftpd With Fling File Transfer Not Working www.centos.org

I have a centos server installation running, and have installed and configured vsftpd. FileZilla works great. I am able to connect and transfer files both ways. I used this just for testing purposes. What I need to do is get Fling File Transfer working. I can connect to vsftpd with Fling, but that is as far as it goes.Sep 20 11:18:44 ftp vsftpd[28286]: warning: can't get client address: Socket operation on non-socketSep 20 11:31:03 ftp avahi-daemon[2240]: Fling's logfile shows this: 11:25:57 Connect: 11:25:57 Connect: Ok 11:25:57 Upload: C:UsersPublicDocumentsFling 1 [code]....

Debian Configuration :: Vsftp Log Not Working? forums.debian.net

I work in a company and we have problems on our server so i decided to investigate. I found first that we don't have any ftp logs. We use vsftpd and i tried unsuccessfully to configure it to write the logs. So here i am: - vsftpd doesn't have any logs (no vsftpd.log file in /var/log/) I added the following lines in the vsftpd.conf : syslog_enable=YES log_ftp_protocol=YES xferlog_enable=YES vsftpd_log_file=/var/log/vsftpd.log [Code].... I also took a look at vsftpd process : it is owned by a user called "nobody" and a user called "www-data" when i upload or download files. Is it a problem of permission on the log file ?

Nokia :: Speed Limits In USA When Using Metric Units Bug discussions.europe.nokia.com

If you use Maps 3.0 in USA and you're driving on a road for which speed limit info is available, there will be a problem, provided you are using metric units.Speed limit seems to be set as a digit, that's not related to a measurement unit.As a result, if speed limit is 65 I will get warning if I drive more than 65 km/h, even though the actual limit is 65 mp/h.I have no wish to change my format to imperial units, but as such speed limits, while driving in the USA are useless.

Actionscript 3 :: Calculating The Current Upload Speed (or Throughput)? stackoverflow.com

I am uploading files using the upload() method of the FileReference class. I want to display the current connection speed and I was wondering what was a good way to do that. My current technique is to use a Timer every 1 mili second such as follows: var speed:Function = function(event:TimerEvent):void { speed = Math.round((currentBytes - lastBytes) / 1024); lastBytes = currentBytes; } var speedTimer:Timer = new Timer(1000); speedTimer.addEventListener(TimerEvent.TIMER, uploadSpeed); and currentBytes gets set into the ProgressEvent.PROGRESS. This technique seems imprecise. I was wondering what other ways I could use to calculate the upload speed while uploading and display it in real time.

CentOS 5 Networking :: Can't Get Vsftpd To Accept Anything But Anonymous Connections www.centos.org

This is on Centos 5.3 by the way..... I had a DVD and, well, just wanted to test some things.. I'm aware that this is not the latest release. And, by the way (I just read an earlier post) I've added the username and password with which I'm trying to login (..hello?). I'm at work and I don't have a copy of my Vsftpd configuration file (don't wanna edit this whole thing - actually there is a copy, below). I've used Slackware for years and never had any issues with Vsftpd - it just works. I am trying Centos because I need help with upgrading my mail server (qmail) and there's not much help for Slackware users. Also, I used to run RHEL3 and had vsftpd working fine (had to copy some file to /etc/pam.d) but it worked famously. I compiled all my web server stuff (just don't like these default things where I have no idea how things are integrated) and I'm hung up on - of all things - vsftpd. Anyway....When I try to log into my ftp server I get "KERBEROS_V4 rejected as an authentication type" and only the anonymous account works. Any other logins produce an error (incorrect login - see ya' later). I have SE Linux and the firewall OFF. I don't recall the directive, precisely, but my vsftpd.conf file is set allow local users to connect. I installed with yum and it added some lines at the bottom (one was about a user list and the other was about PAM). I've got a chroot list and a user list although it's not clear to me precisely where the user list should be placed. I actually uninstalled the RPM and compiled, too. I've done everything but call an exorcist. And I've found tons of posts regarding this on the net and none of the fixes worked. Man - on slackware you type "make" and "make install" (I build it with tcp_wrappers) and you're off to the races. Actually - I did upload the vsftpd.conf file to work (where I'm at, now). Minus lines that were commented out it looks like this: Could it, possibly, be something about how I am adding the user, the shell type, etc? I know that in Redhat I used to type "/usr/sbin/useradd -d /home/someuser joe". I've done it that way and I've also done it like so: "useradd -d /home/schmoe -s /bin/bash schmoe".

Control The Speed Users Upload To The Server? www.phpfreaks.com

is it possible to control the speed users upload to the server. For example if i want to limit a guest to a low speed and a user to higher speed. Can i do this? if so how can i.

Fedora Servers :: Vsftpd Virtual Shows All Of Filesystem forums.fedoraforum.org

Vsftpd virtual users, when a user connects via of ftp they can view all files in the file system. Have a virtual web server and vsftpd working, each user's username is their domain name. FTP works, but not the way I wish for it to work. I only wish for a user to be able to view the files under their username, not the entire Fedora file system and limit changes to files ONLY under their domain name.

How Can Display The Current Upload / Download Bandwidth Usage www.vbforums.com

How can display the current upload / download bandwidth usage example:current upload speed: 12kb/scurrent download speed: 56kb/s

AT&T's Slow 3G Upload Speed forums.macrumors.com

The iPad "+3G" using AT&T's 3G network never logs an upload speed over 357kbps (speedtest.net). Ditto for the iPhone 3Gs. Compare that to the iPad "WiFi only" using the Sprint 4G Overdrive portable hotspot that reaches upload speeds as high as 989kbps.Compare that to the iPad "WiFi only" using the Sprint 4G Overdrive in "3G only" mode where I've seen upload speeds as high as 600kbps.Compare that to the Droid Eris using the Verizon Wireless 3G network where I saw uploads as high as 835Kbps.Am I the only person bothered by the iPad 3G's slow upload speed?

Upload Progress With TCP Connection? www.vbforums.com

I'm using the code below to send text messages, but sometimes I need to send a large text file (500kB - 1,5MB) and I'd like to show the progress.The only way this can be done is by sending the data in smaller parts (I think), but how can I do this properly? BeginWrite is asynchronous and won't wait until a previous part has been uploaded, so tracking the upload progress is not accurate. Is there also a way to limit the upload speed, lets say to 25 kB/s? [Code]...

General :: How To Limit Upload Speed In Android forum.xda-developers.com

I like dropbox's Camera Upload feature, but quite often I find that it will saturate my internet connection and everything else on my network struggles. Especially if it is uploading video recordings off my phone. Is there a way to place a speed limit to the data upload rate? Kind of like a bandwidth limiter for Android?

Red Hat :: Ftp User Can't Create A Directory On Ftp Server? www.linuxquestions.org

i'm using ftp server with RHEL-5.1 now i wish to an anonymous user can create and upload some file on my ftp server...for this i configure the entries in /etc/vsftpd/vsftpd.conf anonymous_enable=YES # Uncomment this to allow local users to log in. local_enable=YES [code]...

Red Hat :: Anonymous User Can't Create A Directory On Ftp Server www.linuxquestions.org

i'm using ftp server with RHEL-5.1 now i wish to an anonymous user can create and upload some file on my ftp server... for this i configure the entries in /etc/vsftpd/vsftpd.conf anonymous_enable=YES # Uncomment this to allow local users to log in. local_enable=YES [code]....

Ubuntu Servers :: Can't Modify FTP \ Managed To Create A FTP Server By Using Apt-get Vsftpd? ubuntuforums.org

I'm completely new to Linux/Ubuntu, but I managed to create a FTP server by using apt-get vsftpd or something.I followed a tutorial and modified a file called vsftpd.conf.I tried to disable all kind ofblocking/permissions. From a Windows client, I can connect to it without any login (I enabled anonymous) and I can download from it, but I am unable to modify it or upload files. Unless there is a better way to transfer files between the computers, how can I enable writing on the FTP server?

File -limit Speed Of Outgoing Response From Script? stackoverflow.com

How to limit speed of outgoing response from php script? So I have a script generating data in keep-alive connection. It just opens file and reads it. How to limit outgoing speed (By now i have such code) if(isset($_GET[FILE])) { $fileName = $_GET[FILE]; $file = $fileName; if (!file_exists($file)) [Code].... So what shall I do to limit speed of response (limit to for example 50 kb/s)

Limit File Size Or Request Size forums.devshed.com

I developed a web application and it is working fine, except for one issue. The application includes uploading files from a JSP to my servlet, and the issue is that i would like to have a limit for the uploaded files on the client side (before actually uploading it). I investigated alot and found some ways like changing my JSPs to PHPs, which is not feasable for my application. I would also like to add that using the Flash component ("<object>") for uploading is not feasable also at this time. Using ActiveX does not work also (for some security issues in javascript, it can not access the system information, also ActiveX works only on IE). I would like to add that I have my application running on Oracle application Server, JSPs for displaying the forms, MultiPart Java API for getting the form input values and files to my servlet and everything is developed in JAVA. Either by limiting the file size or the limiting the whole request size sent to the servlet.

Red Hat / Fedora :: 550 Permission Denied Error Message (Cannot Upload File) www.linuxforums.org

I have got centos 5.3 running on my system. I have installed vsftpd and created a separate folder to upload files (upload folder created in/var/ftp/pub). From my client end I can download ftp files but when I try to upload files from my client I get a error message 550: permission denied. The upload folder has full permission ie 777. Checked the ftp config file everything looks ok. ftp config file 12 anonymous_enable=YES 15 local_enable=YES 27 anon_upload_enable=YES

Slackware :: Newly Uploaded Slackware Packages? www.linuxquestions.org

I have uploaded some slackware packages to ftp://ftp.herpderp.ca/slackpkg/. These are packages that I haven't been able to find anywhere else and they are all built on a clean slackware 13.0 system using slackbuilds from slackbuilds.org. I will be uploading more in the future as I build them.

Upload Transfer Rate Limit Problem www.vbcity.com

Hello thereI have been creating my own small file sharing program for network use (And Internet). I have a problem though. I have figured out how to limit the Upload Speed, but i have a problem getting my speeds to what i want. When I use a timer to limit the uploads, it goes slower than its supposed to. However, if I increase my chunk size, then the upload speed increases. But i cant make the Chunk size too big, or else I start to lose bits during the transfer and the file is unreadable upon completion. I also tried sending the file without using the timer, and i get about 3MB/s, but again, i lose bits during transfer and I have NO control over the speed. Does anyone have any suggestions on how to limit the upload speed to ANY set amount?Code: Do While UpInfo.Blocks(Index) > 0........If UpInfo.Nxt(Index) And UpLimiter(Index) Then         If UpInfo.Blocks(Index) = 1 Then                UpInfo.BufferLen(Index) = LOF(BinFileNumUpl(Index)) - Loc(BinFileNumUpl(Index))where Uplimiter(Index) is Timer controlled and UpInfo.Nxt(Index) is the readiness status of the recieving end.When i get rid of Uplimiter, my uploads are extremely fast depending on the chunk size.I Hope Someone Can HelpThanks

Ubuntu :: 10.10 - Using Apt-get To Install Vsftpd? ubuntuforums.org

I need to get a FTP daemon running on my computer, so I tried to install vsftpd It worked, but later I wanted to try pure-ftpd so I removed vsftpd. Then I discovered I wanted to go back to vsftpd, so I removed pure-ftpd. Now when I type Code: sudo apt-get install vsftpd It returns something like this Code: nossr50@robert-HAL9000:~$ sudo apt-get install vsftpd [sudo] password for nossr50: Reading package lists... Done Building dependency tree [code]....

Ubuntu :: Stop VSFTPD Daemon From Loading At Boot? ubuntuforums.org

I installed VSFTPD via: sudo gedit /etc/vsftpd.conf I can start/stop using the following: sudo /etc/init.d/vsftpd start sudo /etc/init.d/vsftpd stop By default, the daemon loads at boot but I don't want/need it to. I executed the following command thinking it would stop it from loading at boot code... Can anyone tell me how to stop the VSFTPD daemon from loading at boot?

Slackware :: H Article: Vsftpd Backdoor Discovered In Source Code? www.linuxquestions.org

Before anyone panics, the source tarball for Slackware 13.37 doesn't appear to be the "bad" tarball that Chris Evans mentions here: [URL] Code: $> sha256sum vsftpd-2.3.4.tar.gz b466edf96437afa2b2bea6981d4ab8b0204b83ca0a2ac94bef6b62b42cc71a5a vsftpd-2.3.4.tar.gz I checked str.c for the call to vsf_sysutil_extra() if the user is specified as and I also checked for the rogue shellcode in sysdeputil.c but I didn't find it, so it looks like the backdoor was uploaded recently. [URL] Quote: Chris Evans, aka Scary Beasts, has confirmed that version 2.3.4 of vsftpd's downloadable source code was compromised and a backdoor added to the code. Evans, the author of vsftpd - which is described on its web site as "probably the most secure and fastest FTP server for Unix-like systems" - was alerted on Sunday to the fact that a bad tarball had been downloaded from the vsftpd master site with an invalid GPG signature. It is not known how long the bad code had been online. The bad tarball included a backdoor in the code which would respond to a user logging in with a user name "" by listening on port 6200 for a connection and launching a shell when someone connects.Evans has now moved the source code and site to [URL] a Google App Engine hosted site. The GPL-licensed source code can be downloaded (direct download) from the same site, along with the GPG signature for validating the download, a step that Evans recommends. Evans says that the lack of obfuscation and lack of victim identification leads him to believe that "perhaps someone was just having some lulz instead of seriously trying to cause trouble".

VS 2010 Uploading Raw Directory? www.vbforums.com

Any kind of ways to upload raw directory with files like: Webbrowser1.navigate to ftp server and drag and drop files to browser and it uploads them.I can use application like that for upload my latest releases automaticly there with pressing a button without choosing the files. I want to upload whole directory there.Any ways to upload directory to FTP server or just some webserver? Simple way to upload is put ftp address to webbrowser and drag files to browser and it starts uploading immediately.

Ubuntu Servers :: Users On The Machine Can Login Into Vsftpd With Their Username And Password On The... ubuntuforums.org

I recently installed vsftpd on my server. I noticed that users on the machine can login into vsftpd with their username and password on the machine and go to their root dir "/home/username".Now, I want to give some people a vsftpd username and password so they can upload and download files and folders to their folder, but this folder has to be in the "/var/www/(username)" folder. I don't want them to be able to go to any other folder than their own folder like "/var", "/etc" or "/home" etc. Also I don't want them to be able to login on the machine as a user, through putty for example. They should only be allowed to acces their folder with vsftpd, nothing else.

Ubuntu :: Limit Upload Speed Of Certain Devices Such As Ps3? ubuntuforums.org

There is a ps3 in my house which i play with an online connection, i also download alot of stuff. so i want to limit the upload speed of the ps3 to give my downloads more speed. i have verizon fios.

Ubuntu Servers :: Vsftpd - Users Can't Download? ubuntuforums.org

I'm using vsftpd on my server. When I connect (using file-zilla) from other computers on the same network I can't download any files. I can upload, create directories, and delete stuff, but I can't download. I've disabled anonymous access and enabled local user log-in. My /etc/vsftpd.conf Code: # Example config file /etc/vsftpd.conf # # The default compiled in settings are fairly paranoid. This sample file # loosens things up a bit, to make the ftp daemon more usable. # Please see vsftpd.conf.5 for all compiled in defaults. [Code]...